Windows Task Scheduler - Run task nonstop

Yoshi

New Member
#1
I have a task/script, that I need to run nonstop.

However, I have set up the task, and I keep trying to run it. It does run, but after I refresh the tasks, it stops, says "Ready," and also says "Task Completed."

The thing is, I was able to do this before, and it continued running.

My question is, how can I make Task Scheduler continue to run nonstop? Any help would be appreciated.
 

Admin

Administrator
Thành viên BQT
#2
The Task-Scheduler can not automatically wait on every derived process / application beeing executed. Once the main handle "finishes", the task is considered completed, and it's status turns to ready, even if there is still stuff running in the Background.

Example:

Consider two tasks, with the following actions:

  1. Program cmd.exe, Parameters: /c pause
  2. Program cmd.exe, Parameters: /c "start cmd.exe /c pause"
In case 1, the taskscheduler will say "running", until the cmd window closes. (Which is what you are asking for?) Case 2 invokes an action from within the first cmd window. So, even if the SECOND cmd-window remains open, the process created by the taskscheduler itself terminates - hence it considers the execution completed and switches back to "ready".

So: Make sure, your main-process started by the task scheduler (and maybe invoking other processes) does not end, before all the work is done.

in the above example, this could be achived like

  1. Program cmd.exe, Parameters: /c "start /wait cmd.exe /c pause"
window 2 will be "paused" and window 1 waits for window 2 to close, leaving that process in an active state. So, the task scheduler keeps displaying "running".

to provide a less generic answer, you should update your question with more information: What task are you executing? What kind of script is it? What are you task settings, and what is your expected behaviour?
 
OP
OP
Y

Yoshi

New Member
#3
That exactly what I forgot to do. I forgot to make it run as CMD. I was trying to make my crypto miner run in the background, so I have it run as SYSTEM so no cmd window pops up.
 

Từ khóa phổ biến

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top